Question

Error when setting up LinkedIn SSO

  • 20 July 2021
  • 4 replies
  • 383 views

Userlevel 6
Badge +4

I am trying to set up the LinkedIn App for Docebo to allow users to log in using their LinkedIn credentials. Has anyone done this? I have two issues:

  1. I am getting an error “The redicrect_uri does not match the registered value” error when the user clicks on the LinkedIn button from the login popup. The Docebo documentation says to put the following in the OAuth settings for the Redirect URL: https:  // yourplatformurl/lms/index.php  which I have done (https://wingsforkids.docebosaas.com/lms/index.php) but that throws the error. 
  2. The reason I went down this rabbit hole is because I set up the LinkedIn Learning integration with Docebo and I know it’s linked properly and I have successfully imported a couple of test courses and enrolled some users. But when the user starts the course they get a error message:

    Oops!

    It’s not you. It’s us. Give it another try, please.

    Try again

Try again doesn’t work. Eventually it throws you into LinkedIn Learning but not the actual course you were trying to take and I can’t tell who the “logged in” user is. It’s weird. This is a support case right now but I can tell based on convo with support rep that they don’t have a quick answer for this. Thought I’d try to get a jump ahead and see if any techies out here in the community have any advice here. Thanks.

 

 -Cindy


4 replies

Userlevel 5
Badge +1

If you are already logged into LinkedIn.com in the browser that you’re using that error msg shouldn’t come up… I’m interested in what we find out here. 

Userlevel 1

Hi @Cindy McElhinney do you happen to recall what resolution worked for this issue?

Userlevel 6
Badge +4

@orobinson My memory is a little rusty on this but here’s are my exact notes that I saved regarding the fix...hopefully it will give you a few clues….

1. Enabled two products on the LinkedIn Developer App: Share on LinkedIn and Sign in with LinkedIn

2. Changed our authorized URL under the Auth settings to https://www.wfklearningcenter.org/lms/index.php.  (Had to add the www)

I’ll keep looking to see if I can find anything else. 

Userlevel 1

Thank you very much!

 

Reply