Best Answer

Sign in page background video

  • 24 October 2022
  • 3 replies
  • 84 views

Userlevel 3

Hi everyone,

We have created a beautiful video we want to use for our background on the sign in page.

The video contains audio but when I upload it and then go to the sign in page, there is no audio.

Does anyone know if audio is possible for this? Is it a CSS issue?

Thanks in advance for any and all help.

icon

Best answer by gstager 24 October 2022, 18:51

View original

3 replies

Userlevel 7
Badge +5

Not a CSS issue. 

Another possibility are the autoplay restrictions in the browsers that require some sort of interaction with the media before the audio will play.

That said - if there is no button or something to interact with stuck with no audio.

Plus - if there is a limitation within Docebo for the login page audio - well - then we would still be stuck even if we could get past the browser autoplay restrictions.

Userlevel 7
Badge +3

Yeah, I am guessing as I don’t have access to a login page that uses a background video, but it is generally best practice when using the video attribute to include the mute marker. It is very bad practice to have a page start playing audio on page load from a user experience as well as an accessibility standpoint and as Greg mentioned, most browsers have moved to override video settings to mute anyways even if the option existed. 

Only way around I could think of is to basically use the custom CSS to replace the background with a video manually instead of the built in option, you could then technically control and insert some controls, but still not a great idea.

Userlevel 3

It is very bad practice to have a page start playing audio on page load from a user experience as well as an accessibility standpoint and as Greg mentioned, most browsers have moved to override video settings to mute anyways even if the option existed. 

 

Very good point. Thank you. I will rethink our sign in page video. 

Reply