Best Answer

Group + Auto-enrollment troubleshooting

  • 17 February 2022
  • 6 replies
  • 308 views

Userlevel 3
Badge +1
  • Helper II
  • 26 replies

I need help troubleshooting: We have an ILT that users can only access once they’ve started a specific course. Ideally, we want users to see the course exists but can’t be accessed yet.

Current setup:

  • Group “ILT”: Automatically assign users to group “ILT” if at least one of the conditions is satisfied: The course is in progress or completed
  • Enrollment rule: If user is in group “ILT,” enroll user in the ILT
  • ILT settings:
    • Course Visibility in Catalogs: Show the course in internal and external catalogs
    • Course Self-Enrollment: Self-enrollments are available
    • Catalog Enrollment Policy: Only Admins can enroll learners
    • Validity is not limited
    • Course is published

Until a few days ago, this setting worked. Now it doesn’t: The course stays locked even though my test learner account is assigned to the correct group. The message on the card says “This course is now locked” which sounds like it wasn’t locked before but I can’t remember what the locked course message was when it was still working. I’ve played with the settings and with a new test user account but it’s always completely locked or freely accessible. I’ve set up a second test ILT to start clean and minimize the chance of dependencies I’m not thinking of, but it’s the same thing.

I don’t know what could be interfering with it and why it used to work but now doesn’t.

  • Any suggestions how to fix this or alternative ways to make this work?
  • Could this possibly be a consequence of all the Docebo updates that are currently happening?
  • Does anyone know when the Docebo learning plan updates will be rolled out where you can add an optional course to a learning plan? That could also solve the problem.
icon

Best answer by alekwo 17 February 2022, 12:53

View original

6 replies

Userlevel 7
Badge +1

@LSP I hope I’m not stating the obvious, but note that the enrollment rule, is not really:

  • Enrollment rule: If user is in group “ILT,” enroll user in the ILT

but rather

  • Enrollment rule: when user is added to the group “ILT,” enroll user in the ILT

Meaning, that users who were in the group when you created the rule, are not automatically enrolled. Only users who are newly added to the group will get enrolled - there is a log available in the enrollment rules to see if they were triggered.

 

To test the whole scenario,

  • I’d start with making sure, that the test user is not in the group (is not enrolled in the first course).
  • Check if they see the course as locked.
  • Then, I’d check if the user will be properly added to the group once they fulfill the group criteria.
  • And finally validate if the enrollment rule is triggered for them when they are added to the group.

 

Another thing I caught myself more than once, is that enrollment rules are not activated when you create them, you need to manually activate each enrollment rule to make it work.

Userlevel 3
Badge +1

Hi @alekwo, thanks for taking the time to respond. I guess I should have elaborated more but the post already got so long. Yes, I created a third (and fourth and fifth) user after I made changes since the groups page warns you that it only applies going forward but not retroactively. But thanks for the reminder of the Enrollment Rule Log, I forgot about that!

Here’s some of the behavior I’ve seen:

  • One user got assigned to the group as expected, but the Enrollment Rule didn’t trigger
  • Another user didn’t get assigned to the group (same settings as for the user that got assigned). But when I added that user manually, the Enrollment Rule triggered as expected.

It’s that inconsistency and that it had worked before that made me think it could be related to the updates happening in Docebo, I’ve seen some random weird things happening lately and thought this might be one of them.

Userlevel 7
Badge +1

Hi @LSP that’s odd.

I think that the best course of action would be to contact Docebo support and ask them to investigate in the backend why the enrollment rule is not triggered.

We use group based rules for a few courses, and so far I didn’t notice any hick-ups, but also, I wasn’t monitoring them too closely, for sure will start looking at them with more attention.

Userlevel 3
Badge +1

@alekwo It very likely was a temporary bug. I haven’t gotten around to contacting support and when I made another test today is was working again. Let’s hope it stays that way!

Userlevel 3
Badge

It is the temporary bugs that get you. :) Thank you for the reminder though to check these periodically. We have some set up that are critical so we need a check every few months.

Userlevel 3
Badge +1

@tonya.clark Yeah, but those temporary bugs eat up so much time! We’re still implementing Docebo so any unexpected behavior could be due to a hundred different things. Sometimes I see something weird like the course management page telling me there are no courses and I just slowly back away and decide to check back later...

Reply