Best Answer

Moving learners between Learning plans

  • 14 October 2021
  • 3 replies
  • 24 views

Badge

I’m trying to move learners from one LP to another. The target LP is a new “generation” of the LP, and I need everyone who in incomplete in the source LP to get assigned to the target LP. I’m trying to do this with groups and enrollment rules, but nothing is happening. 

I have the enrollment rule configured as groups/learning plan.

I have enabled the enrollment rule before assigning the groups.

Thanks for any help.

icon

Best answer by lrnlab 14 October 2021, 21:08

View original

3 replies

Userlevel 7
Badge +5

Hi @KMallette Enrollment Rules can be tricky...pay careful attention the disclaimer in the KB article:

https://help.docebo.com/hc/en-us/articles/360020128579-Activating-and-Managing-the-Enrollment-Rules-App

  1. So you need to create the GROUP first so you can use it with the Enrol Rule but do not include the actual details so that the group does not yet capture any users
  2. then, create your Enrollment Rule (make sure it’s active)
  3. go back to your Group and finish adding your criteria
  4. When prompted to SAVE it will them process your criteria and add users to the Group

from that point the rule runs almost instantly.

I was having trouble with this as well as I created my Groups first (logical) followed by the rules and nothing worked. I then did a test where I used another test (not yet in the group) and added the criteria that would add them to the group...and voila, they were assigned.

Hope this helps you to sort this out.

Badge

Hi @KMallette Enrollment Rules can be tricky...pay careful attention the disclaimer in the KB article:

https://help.docebo.com/hc/en-us/articles/360020128579-Activating-and-Managing-the-Enrollment-Rules-App

  1. So you need to create the GROUP first so you can use it with the Enrol Rule but do not include the actual details so that the group does not yet capture any users
  2. then, create your Enrollment Rule (make sure it’s active)
  3. go back to your Group and finish adding your criteria
  4. When prompted to SAVE it will them process your criteria and add users to the Group

from that point the rule runs almost instantly.

I was having trouble with this as well as I created my Groups first (logical) followed by the rules and nothing worked. I then did a test where I used another test (not yet in the group) and added the criteria that would add them to the group...and voila, they were assigned.

Hope this helps you to sort this out.

@lrnlab 

Thank you so much!!! This is just what I needed.

Userlevel 7
Badge +5

@KMallette did this work for you?

Reply