Question

Certification and Retraining

  • 9 September 2022
  • 2 replies
  • 148 views

Userlevel 3
Badge

Hello,

If you manually award a learner a certification in certification and retraining and they are not enrolled onto the course as they have previous experience but you want them to update in XXmonths when the learner click ‘renew now’ will they be enrolled onto the course to complete?

Hope that makes sense.

Thanks

Ant


2 replies

Userlevel 7
Badge +8

Hi @AntRich76 although I have never tried this, I would imagine that it should since the certification is tied to a course, courses and/or LP’s.

Once the user clicks RENEW, it automatically resets the course status is you've checked the option to allow the user to complete the same courses/LP for their renewal.

If choose not sure this option, I’m not sure it will enrol the user as they could choose any of a number of courses/LPs to achieve their certification.

You should create a test case and see how it behaves

Userlevel 5
Badge +1

@AntRich76 I tried a scenario similar to this at implementation.  I had a set of courses with historical dates that I linked to the certification app.  I first imported all the completion dates using Docebo services (they used API I think), and then granted the audience the certification. 

While the users activity profile did reflect a date to complete the retraining by and it was aligned to their completion date, the ‘renew now’ button was not functioning as intended and users couldn’t complete the retraining. 

The ‘renew now’ button doesn’t directly reset the course status, it actually resets the training object status. If your course reflects 1/1 lessons complete prior to clicking renew now, if you look after clicking renew now it shows 0/1 lessons complete. This will of course impact course status, but it is the direct impact to the training object that’s occurring which changes the course status.

 I ended up having to toggle all completions back to in progress and then back to completed to trigger a completion on the training object itself, and then the renew now button worked as designed.

 

hope this helps!

Reply