New SSL Certificate - old dates still displaying in browser

  • 25 August 2022
  • 7 replies
  • 214 views

Hello
We are trying to upload new SSL certificates to our more than 40 EE domains… but altough the old SSL certs are removed on Docebo before adding a new one, and Docebo shows the newly updated date, when viewing the certificate in the browser it still shows the old date.

Has anyone else come across this issue? 


7 replies

Userlevel 7
Badge +6

@AmmeSim I’ve not encountered this when I’ve changed out my SSL certs. Sounds like it could be related to a browser or cache? Are you tracking browser and suggesting that the user ‘clear cache/cookies’ in order to refresh the SSL? It also sounds like it could be related to how quickly DNS servers update the changes. In this case, I’d expect it to resolve itself with 24/48 hours.

Would love to hear back on how this works itself out.

Regards,

KM

Userlevel 5
Badge

@AmmeSim just to add to what @KMallette said, my understanding is that even when the old one is removed, Docebo will still reference it until the new one is updated on the DNS servers to reflect the new dates that way there is no lapse in the SSL certificate. 

Userlevel 2
Badge

I have seen this issue too. And in my case the ssl works for the main site but not for my extended enterprises. So I know the cert is valid.

Did you resolve the issue?

Userlevel 6
Badge +2

Hi @AmmeSim 

We encountered this problem last month and it resulted in our LMS being inaccessible for more than a day while Docebo fixed the problem.

After installing the new certificate (one month before expiry, just to be sure), the LMS stated that it was successful and presented the new expiry date. However, in reality the new certificate had not taken properly and the old cert was still in place. We had no idea of this, so a month later the old certificate duly expired and the site was broken. 

After a day and a half of troubleshooting, Docebo managed to install the new certificate properly from the back-end. 

It has since been confirmed that there is a bug in the certification management system that arises in specific situations. The recommendation we received was to always check in the browser that the new cert is working (as you very sensibly did!), and if not, notify Docebo tech support so they can install it for us.  

I understand the cert management system is being upgraded / replaced at some stage, but no specific timeframe known yet. My hope is that they also introduce support for LetsEncrypt auto-renewing certs. 

Hope this helps you and others!

Alan

 

Userlevel 7
Badge +6

@Alan Was there any indication that the certificate failed in any particular browser? Or were you EE domains broken in all browsers?

Thanks,

KM/Viasat, Inc.

Userlevel 6
Badge +2

Hi @KMallette It wasn’t browser-specific. The new certificate simply was not in place. The LMS UI said it was installed OK and even displayed the new expiry date. It was not all EE domains, just the one using this particular certificate. 

Alan

Hi @Alan ,

I am having the same issues with you, and also i am using letsencrypts as well for generating SSL cert. I am following your solution to open ticket to solve this case, hope the support teams contact me ASAP.

Regards,
Antonius

Reply