Question

SCORM LO Not Opening For One User

  • 5 August 2022
  • 5 replies
  • 30 views

2 months ago, one particular Learner was able to access SCORM files without any issues. Today, he can’t get any SCORM files in the same course to open (only video LOs will open). Sometimes it’s opening to a blank white screen, other times the new window doesn’t even open, despite the LO settings being set to “Play In New Window.”

I remoted into the Learner’s laptop, made sure that popups & redirects are allowed, as well all cookies being allowed, and I cleared his cache data.

When that didn’t work, I logged in as the Learner from my Admin menu. I couldn't get a particularly important SCORM LO to load either, but was able to open a different SCORM LO, so I thought maybe it was a problem with the SCORM file. But then I received confirmation that other Learners are opening it without a problem.

I then went to the “Learner View” from my Admin menu to see if it would open. I was able to open all SCORM LOs without a problem.

Based on this process, it seems like there’s a problem with this particular Learner’s account since neither he nor I can get this SCORM LO to open, yet every other Learner (4 total) is able to. But that’d be something I haven’t seen before in 3 years with Docebo. Chat Support spent about 5 minutes on it and opened a ticket, meaning I won’t hear back for weeks.

 

Anyone have any ideas on what to do or what I’m missing here?


5 replies

Userlevel 7
Badge +5

So - I will tell you what my spidey sense it telling me.

A users account out of state with a SCO suggests to me that the SCO has seen some overwriting of its structure and the person was at a page in the course that is now either not there or has had an unexpected change in formatting. The learners view is fine for you because the course is not out of state for you.

Lets go over the first piece. @yahrdmeh - has the SCO been overwritten a few times?

If they have - something some folk dont realize is that if a person needs to move forward? If you try reloading your browser with that SCO open? I found that I could move a “broken SCO session” by simply reloading the browser until the learner is at a state that it effectively catches up for them...if the course has ALOT more structure though…..on that new page? Then you may be seriously stuck and may want to consider resetting the training material for the learner all together.

@dklinger The SCO has been overwritten once, however, this particular user has been unable to access this Learning Object since before it was overwritten. The SCO is still in “Not Started” status (not “In Progress”), so there’s no option to reset the Learning Object. Additionally, we can’t even get the SCO to open a new window/browser tab when we try to open it, so we can’t refresh the browser with the SCO open.

 

Thanks for the ideas, keep throwing any and all at me! I’ll try anything at this point.

Userlevel 7
Badge +5

can you impersonate the user / open the SCO and try to reload the browser with the SCO open on-screen?

Userlevel 7
Badge +5

oh wait a minute - the answer may be no to that.

ok - i think you are in a tough place. Send it to the user on paper? 😂

Userlevel 4

So as far as you know the issue is restricted to a single user in a single course, but for all the SCORM LOs in the course? Do you have the SCORM debugging option turned on for your platform?https://help.docebo.com/hc/en-us/articles/360020126759-Using-the-SCORM-Debugging-Option-in-your-Platform

If not, I would suggest you turn it on. Then check what the browser console log shows when you try to launch the SCORM LO from the user’s account and compare that to the console log from another account where the SCO launches.

Since “Sometimes it’s opening to a blank white screen, other times the new window doesn’t even open,” it would be helpful to know if the SCORM package is even initializing communication with the platform. It sounds like it is not for this user account. Which would confirm the problem is with the account, not the SCO. 

Have you tried to unenroll and re-enroll the user to the course?

 

Reply