Best Answer

Courses won't show up in Channels unless you are already enrolled

  • 25 March 2022
  • 12 replies
  • 313 views

Userlevel 3
Badge

Hi all,

I’m not sure what I’m doing wrong, but I cannot get courses to show up in Channels without being enrolled. We have it checked in Advanced settings to Show courses where users can self-enroll in channels. I can get assets to show up if I load them from the front end. I am so confused on why this isn’t working. Please help! 

icon

Best answer by Adam Ballhaussen 25 March 2022, 21:50

View original

12 replies

Userlevel 7
Badge +7

There another post running with the same question…

did you add your courses to a catalogue you have visibility to? That should do it.

 

 

Userlevel 7
Badge +3

Hey @karilynnrussell! Sorry you’re having trouble here. There are a few steps you need to take to ensure that your learners can self-enroll into courses from channels in addition to updating the advanced setting.

 

You can learn more about the exact steps you need to take in the Self-Enrolling into Courses from Channels section of the Creating and Managing Channels knowledge article

 

Here’s an excerpt from that article:

 

Learners can self-enroll into courses from channels only if:

 

I’d wager that you may have missed one or both of these steps in your configuration. Catalogs still serve as the source-of-truth for course visibility for learners. Channels are simply another way to display those courses to learners.

 

Please don’t hesitate to reply with any follow-up questions! We’ll get these courses visible to your learners in channels in no time.

Userlevel 5
Badge +2

hi @karilynnrussell  , my name is Marco, PM for this area

Just a note, there is also a “master switch” to show self enrollment in channels

You can find it in “Advanced Setting”, “Channels” 

you have to activate it , is not active by default

https://help.docebo.com/hc/en-us/articles/360020079900-Managing-the-Platform-Advanced-Settings

Ciao

Marco

Userlevel 1

Hi @Marco.T @Adam Ballhaussen 

I followed all the steps suggested above and unfortunately the LinkedIn Learning courses are not showing in the specific channels that I assigned to. Right now only the courses I am enrolled in, show up in the channel.

 

Kindly advise. Thanks!

Userlevel 3
Badge

@Jenny Eng My issue ended up being a technical glitch where only Super Admins could not view courses in Channels without being enrolled. Docebo put out a fix, but I would start there. Test with a user and power user (with proper settings) to see if they are experiencing the same issue. 

Userlevel 1

Thank you @karilynnrussell for the recommendation. We tried logging in as another user who is not a superadmin, that user couldn’t see those courses.

Userlevel 7
Badge +3

@Jenny Eng I’m sorry you’re still having issues. Can you verify that each of the following criteria are true for at least one of the courses you’re testing?

  • The course is published
  • The Course Enrollment Policy is set to Self-Enrollment
  • The Show courses where users can self-enroll in channels checkbox is checked in Advanced Settings > Channels
  • The course is assigned to at least one catalog that’s visible to the users with whom you’re testing

If you can confirm that each of these criteria are true and your users still can’t see the courses in the assigned channels, please submit a ticket to our support team so that they can help you troubleshoot.

Userlevel 1

@Jenny Eng I’m sorry you’re still having issues. Can you verify that each of the following criteria are true for at least one of the courses you’re testing?

  • The course is published - TRUE
  • The Course Enrollment Policy is set to Self-Enrollment - TRUE
  • The Show courses where users can self-enroll in channels checkbox is checked in Advanced Settings > Channels - TRUE
  • The course is assigned to at least one catalog that’s visible to the users with whom you’re testing - TRUE, course is a LinkedIn Learning course, and we have LinkedIn Learning catalog set up

If you can confirm that each of these criteria are true and your users still can’t see the courses in the assigned channels, please submit a ticket to our support team so that they can help you troubleshoot.

 

Thank you @Adam Ballhaussen , I can verify all the following criteria are true for the courses I am testing. We will submit a ticket to our support team for further troubleshooting. 

Userlevel 7
Badge +3

Thanks for confirming @Jenny Eng, and sorry you’re still having these issues. Please follow up on this thread once you’ve received more information from support. It will greatly help others in the community who might run into a similar problem. Best of luck!

Userlevel 1

Of course, @Adam Ballhaussen. We managed to figure out the issue. This issue is specifically related to LinkedIn Learning courses and content integration with Docebo.

 

When we integrated all LinkedIn Learning courses and content with Docebo, a LinkedIn Learning catalog was created automatically. Since the catalog is an integration and was created automatically, there’s no way to manually add LinkedIn Learning content/courses to the catalog. We also added/assigned users and groups to this catalog. Users/Groups for this catalog consists of all of our employee population.

 

When we add specific LinkedIn Learning courses to a specific channel, we need to ensure for that specific LinkedIn Learning course, catalog is assigned again on the course management level. Even though LinkedIn Learning catalog was created automatically as part of the content integration, we realized each LinkedIn Learning content/course did not have a catalog assigned to it on the course management level.

 

In this case, to ensure unenrolled LinkedIn Learning courses show up on a specific channel, we had to manually assign catalogs to each of the LinkedIn Learning courses via Course Management.

 

I hope I am making sense with my explanations.

 

Our team is trying to work with someone from Docebo who is a direct point of contact on all things Docebo LinkedIn Learning integration to further investigate. Right now, only way around is to manually assign each and every LinkedIn Learning course to a catalog.

Userlevel 7
Badge +3

This is really helpful, thank you for following up @Jenny Eng!

Userlevel 1
Badge

@Jenny Eng I’m sorry you’re still having issues. Can you verify that each of the following criteria are true for at least one of the courses you’re testing?

  • The course is published - TRUE
  • The Course Enrollment Policy is set to Self-Enrollment - TRUE
  • The Show courses where users can self-enroll in channels checkbox is checked in Advanced Settings > Channels - TRUE
  • The course is assigned to at least one catalog that’s visible to the users with whom you’re testing - TRUE, course is a LinkedIn Learning course, and we have LinkedIn Learning catalog set up

If you can confirm that each of these criteria are true and your users still can’t see the courses in the assigned channels, please submit a ticket to our support team so that they can help you troubleshoot.

 

This part of the answer helped me with my issue of courses displaying for me (admin) but not for others: “The course is assigned to at least one catalog that’s visible to the users with whom you’re testing”

 

Reply