Enrollment Rules not triggering


Has anyone else experience issues with the enrollment rules not triggering for new users?


13 replies

Userlevel 1

Yes, and I opened a ticket with Docebo on it.

Userlevel 2

Are your new users active?

 

I ran into an issue not too long ago where my enrollments rules weren’t firing. In my case, it was because my users weren’t active (enrollment rules will not fire for deactivated users). It was confusing because those users joined my automatic user groups okay, but didn’t get auto-enrolled into anything, even when I went back in and activated them (..now I just make sure my users are active before they get pulled into any of my automatic user groups).

Userlevel 1

Ours are otherwise they also wouldn’t pull into the groups since the groups are set up to only pull in active users

Users are active. They are being populated into the LMS, they are being assigned into the correct groups. But the enrollments rules are not triggering for some. We had to open a ticket with Docebo as well. A fix has been issued for March 17th. 

Userlevel 7
Badge +1

This has happened a few times for a few reasons, make sure to open a ticket to trace down the exact cause. With group rules we often run into issues of needing to literally just refreshing the group a bit to push the enrollments. The enrollments are also often delayed based on full system usage and not imediate.

Hi, does anyone know if this is resolved? I have set up my groups today which has pulled my users into them. I then went on to do the enrolment rules but these are not allocating the learning plans to the users within the group. Seems a bit back to front having to then go back and refresh the groups as groups need to be set up before enrolment rules.

I am having an issue with enrollment rules triggering for a group that was hired previously. What is the order? I have tried creating the rule, adding the notification, adding the learning plan and then saving changes. Then creating a group, updating the notification. Activating the enrollment - Then adding the group. None of the ways I have tried this process have worked. Any tips?

When you have created the group have you manually added users to the group or built rules to add users? Either way users have to be added to the group after the enrolment rules have been saved. It’s a little backwards as you need the group created before the enrolment rules and when creating the group with a rule it automatically assigns the users. What I done because my groups and enrolment rules were set up already was change the group rule to something unrealistic or add a rule and save, this removed all users from the group. Then changed back to what the group rule was and saved again, this reassigned the users to the group and triggered the enrolment. 
 

Hope this helps! 

Userlevel 7
Badge +1

I also find when I’m making new ones that I try to check too fast if they impact large amounts of users especially, it gets throttled for system performance so takes a little patience sometimes, but have definitely had it broken before too. Have also had issues where have to just re-open a group, make no changes and just save to retrigger things. 

We’ve had some inconsistent results with enrollment rules as well.  One thing we tend to hit a lot is that groups process users shortly after creation, but enrollment rules are not retroactive.  Not sure if we put feature requests here, but is there a way at the end of creating an enrollment rule, the option to say process enrollment rule for all existing groups assigned? Yes to process retroactively similar to group creation and No if we want the enrollment rule to be active moving forward? Thanks!

Userlevel 7
Badge +1

We’ve had some inconsistent results with enrollment rules as well.  One thing we tend to hit a lot is that groups process users shortly after creation, but enrollment rules are not retroactive.  Not sure if we put feature requests here, but is there a way at the end of creating an enrollment rule, the option to say process enrollment rule for all existing groups assigned? Yes to process retroactively similar to group creation and No if we want the enrollment rule to be active moving forward? Thanks!

Sounds like you should open an idea thread and see if you can get some votes together for it for the product team to take notice. 

Sounds like you should open an idea thread and see if you can get some votes together for it for the product team to take notice. 

Thank you @Bfarkas! I just put it in the idea thread.  I appreciate the help. :)

 

Userlevel 7
Badge +1

And just like that ya got some votes! 

Reply